Table of Contents
Problem
Objective
In this challenge, you will learn the usage of the for loop, which is a programming language statement that allows code to be repeatedly executed.
The syntax for this is
for ( <expression_1> ; <expression_2> ; <expression_3> ) <statement>
- expression_1 is used for initializing variables which are generally used for controlling the terminating flag for the loop.
- expression_2 is used to check for the terminating condition. If this evaluates to false, then the loop is terminated.
- expression_3 is generally used to update the flags/variables
A sample loop will be
for(int i = 0; i < 10; i++) { ... }
Task
For each integer n in the interval [a,b] (given as input) :
- If 1<= n , then print the English representation of it in lowercase. That is “one” for 1, “two” for 2, and so on.
- Else if n > 9 and it is an even number, then print “even”.
- Else if n < 9 and it is an odd number, then print “odd”.
Input Format
The first line contains an integer, a.The second line contains an integer, b.
Constraints :-
1<=a<=b<=10^6
Output Format
Print the appropriate English representation,even
, or odd
, based on the conditions described in the ‘task’ section.
Sample Input
8 11
Sample Output
eight nine even odd
Solution :-
// For Loop in C - Hacker Rank Solution #include <stdio.h> #include <string.h> #include <math.h> #include <stdlib.h> int main() { int a, b; scanf("%d\n%d", &a, &b); // Complete the code. // For Loop in C - Hacker Rank Solution START char *str[] = {"one", "two", "three", "four", "five", "six", "seven", "eight", "nine", "even", "odd"}; scanf("%d\n%d", &a, &b); for (int i=a; i<=b; i++)// i= 8 { if (i <= 9) { printf ("%s\n", str[i-1]); } else { printf ("%s\n", str[9+(i%2)]); } // For Loop in C - Hacker Rank Solution END } return 0; }
Another Solution
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
int main()
{
int a, b;
int n=0;
scanf("%d\n%d", &a, &b);
for(n=a;n<=b;n++)
{
if(n==1)
{
printf("one\n");
}
if(n==2)
{
printf("two\n");
}
if(n==3)
{
printf("three\n");
}
if(n==4)
{
printf("four\n");
}
if(n==5)
{
printf("five\n");
}
if(n==6)
{
printf("six\n");
}
if(n==7)
{
printf("seven\n");
}
if(n==8)
{
printf("eight\n");
}
if(n==9)
{
printf("nine\n");
}
if(n>9)
{
if(n%2==0)
{
printf("even\n");
}
else {
printf("odd\n");
}
}
}
return 0;
}